Ceci est une ancienne révision du document !


Kivy: Buildozer avec python 2.7

Python 2.7 c'est fini très bientôt Python2 c'est fini dans ... Mais comme guido n'est plus là, twitter réussira peut-être à le conserver !!!

Cette page ne concerne que python 2.7 Pour python 3.5, voir la page Buildozer avec python 3.5

Utiliser VirtualBox avec 2 systèmes invités différents si vous utilisez python3.5 et python2.7 pour divers projets.

Twisted n'est pas entièrement porté en python3. Kivent ne marche pas en python3.

Installation de dépendances systèmes diverses:

sudo apt-get install autoconf automake build-essential cmake caja-open-terminal libav-tools git python-pip python-dev pkg-config libsdl2-dev python-setuptools ffmpeg libsdl2-dev libsdl2-image-dev libsdl2-mixer-dev libsdl2-ttf-dev libportmidi-dev libswscale-dev libavformat-dev libavcodec-dev zlib1g-dev libgstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-good

Vérifier la version de cython à installer:

sudo pip install --upgrade cython==0.23
sudo pip install pygame
sudo pip install kivy

debian Stretch 9.4 mars 2018

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install build-essential ccache git libncurses5:i386 libstdc++6:i386 libgtk2.0-0:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 libidn11:i386 python2.7 python2.7-dev openjdk-8-jdk unzip zlib1g-dev zlib1g:i386
sudo apt-get install openjdk-8-source libssl-dev openssl
sudo pip install colorama sh appdirs jinja2 six pyopenssl
sudo pip install buildozer

Les sources avec les sorties terminal sur github et avec un apk dans le dossier /bin pour tester et jouer !

sudo pip install twisted

Février 2018 Debian 9.2 Stretch

Download error on https://pypi.python.org/simple/incremental/: unknown url type: https -- Some packages may not be found!
Couldn't find index page for 'incremental' (maybe misspelled?)
Download error on https://pypi.python.org/simple/: unknown url type: https -- Some packages may not be found!
No local packages or download links found for incremental>=16.10.1

distutils.errors.DistutilsError: Could not find suitable distribution for Requirement.parse('incremental>=16.10.1')

[WARNING]: ERROR: /media/data/3D/projets/android_server/.buildozer/android/platform/build/build/python-installs/android_server/bin/python.host failed!
# Command failed: /usr/bin/python -m pythonforandroid.toolchain create --dist_name=android_server --bootstrap=sdl2 --requirements=kivy,twisted --arch armeabi-v7a --copy-libs --color=always --storage-dir=/media/data/3D/projets/android_server/.buildozer/android/platform/build

Post stackoverflow pour une solution

  • kivy_buildozer_avec_python_2.7.1546541009.txt.gz
  • Dernière modification: 2019/01/03 19:43
  • par serge